SQL Injection Affecting mapserver package, versions <6.4.1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.22% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-MAPSERVER-281457
  • published5 Jan 2014
  • disclosed5 Jan 2014

Introduced: 5 Jan 2014

CVE-2013-7262  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Debian:8 mapserver to version 6.4.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mapserver package and not the mapserver package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

SQL injection vulnerability in the msPostGISLayerSetTimeFilter function in mappostgis.c in MapServer before 6.4.1, when a WMS-Time service is used, allows remote attackers to execute arbitrary SQL commands via a crafted string in a PostGIS TIME filter.

CVSS Base Scores

version 3.1