Race Condition Affecting mysql-5.5 package, versions <5.5.35+dfsg-1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.35% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-MYSQL55-352967
  • published19 Aug 2013
  • disclosed19 Aug 2013

Introduced: 19 Aug 2013

CVE-2013-2162  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Debian:8 mysql-5.5 to version 5.5.35+dfsg-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mysql-5.5 package and not the mysql-5.5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Race condition in the post-installation script (mysql-server-5.5.postinst) for MySQL Server 5.5 for Debian GNU/Linux and Ubuntu Linux creates a configuration file with world-readable permissions before restricting the permissions, which allows local users to read the file and obtain sensitive information such as credentials.

CVSS Base Scores

version 3.1