Cross-site Scripting (XSS) Affecting nagios3 package, versions <3.2.3-3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.93% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-NAGIOS3-326352
  • published3 May 2011
  • disclosed3 May 2011

Introduced: 3 May 2011

CVE-2011-1523  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:8 nagios3 to version 3.2.3-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nagios3 package and not the nagios3 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in statusmap.c in statusmap.cgi in Nagios 3.2.3 and earlier allows remote attackers to inject arbitrary web script or HTML via the layer parameter.

CVSS Base Scores

version 3.1