Access Restriction Bypass Affecting nagios3 package, versions <3.4.1-4


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.34% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-NAGIOS3-326354
  • published10 Feb 2014
  • disclosed10 Feb 2014

Introduced: 10 Feb 2014

CVE-2013-2214  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Debian:8 nagios3 to version 3.4.1-4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nagios3 package and not the nagios3 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

status.cgi in Nagios 4.0 before 4.0 beta4 and 3.x before 3.5.1 does not properly restrict access to certain users that are a contact for a service, which allows remote authenticated users to obtain sensitive information about hostnames via the servicegroup (1) overview, (2) summary, or (3) grid style in status.cgi. NOTE: this behavior is by design in most 3.x versions, but the upstream vendor "decided to change it for Nagios 4" and 3.5.1.

CVSS Base Scores

version 3.1