Cross-site Scripting (XSS) Affecting nagios3 package, versions <3.4.1-1


Severity

Recommended
0.0
low
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.87% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-NAGIOS3-326356
  • published14 Jun 2011
  • disclosed14 Jun 2011

Introduced: 14 Jun 2011

CVE-2011-2477  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:8 nagios3 to version 3.4.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nagios3 package and not the nagios3 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Multiple cross-site scripting (XSS) vulnerabilities in config.c in config.cgi in Icinga before 1.4.1, when escape_html_tags is disabled, allow remote attackers to inject arbitrary web script or HTML via a JavaScript expression, as demonstrated by the onload attribute of a BODY element located after a check-host-alive! sequence, a different vulnerability than CVE-2011-2179.

CVSS Base Scores

version 3.1