OS Command Injection Affecting nagios3 package, versions <3.0.6-5


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
83.45% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-NAGIOS3-326370
  • published1 Jul 2009
  • disclosed1 Jul 2009

Introduced: 1 Jul 2009

CVE-2009-2288  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:8 nagios3 to version 3.0.6-5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nagios3 package and not the nagios3 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

statuswml.cgi in Nagios before 3.1.1 allows remote attackers to execute arbitrary commands via shell metacharacters in the (1) ping or (2) Traceroute parameters.

CVSS Base Scores

version 3.1