Cross-site Request Forgery (CSRF) Affecting nagios3 package, versions <3.0.6-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.19% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-NAGIOS3-326373
  • published10 Nov 2008
  • disclosed10 Nov 2008

Introduced: 10 Nov 2008

CVE-2008-5028  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade Debian:8 nagios3 to version 3.0.6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nagios3 package and not the nagios3 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Cross-site request forgery (CSRF) vulnerability in cmd.cgi in (1) Nagios 3.0.5 and (2) op5 Monitor before 4.0.1 allows remote attackers to send commands to the Nagios process, and trigger execution of arbitrary programs by this process, via unspecified HTTP requests.

CVSS Base Scores

version 3.1