Resource Management Errors Affecting netty-3.9 package, versions <3.9.0.Final-1+deb8u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.33% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-NETTY39-546855
  • published6 Feb 2020
  • disclosed6 May 2014

Introduced: 6 May 2014

CVE-2014-0193  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

Upgrade Debian:8 netty-3.9 to version 3.9.0.Final-1+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream netty-3.9 package and not the netty-3.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

WebSocket08FrameDecoder in Netty 3.6.x before 3.6.9, 3.7.x before 3.7.1, 3.8.x before 3.8.2, 3.9.x before 3.9.1, and 4.0.x before 4.0.19 allows remote attackers to cause a denial of service (memory consumption) via a TextWebSocketFrame followed by a long stream of ContinuationWebSocketFrames.

CVSS Base Scores

version 3.1