HTTP Request Smuggling Affecting netty-3.9 package, versions <3.9.0.Final-1+deb8u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
13.83% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-NETTY39-546857
  • published30 Jan 2020
  • disclosed29 Jan 2020

Introduced: 29 Jan 2020

CVE-2019-20445  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade Debian:8 netty-3.9 to version 3.9.0.Final-1+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream netty-3.9 package and not the netty-3.9 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

HttpObjectDecoder.java in Netty before 4.1.44 allows a Content-Length header to be accompanied by a second Content-Length header, or by a Transfer-Encoding header.

References

CVSS Base Scores

version 3.1