Directory Traversal Affecting okular package, versions <4:4.14.2-2+deb8u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.85% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-OKULAR-264815
  • published25 Sept 2018
  • disclosed6 Sept 2018

Introduced: 6 Sep 2018

CVE-2018-1000801  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Debian:8 okular to version 4:4.14.2-2+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream okular package and not the okular package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

okular version 18.08 and earlier contains a Directory Traversal vulnerability in function "unpackDocumentArchive(...)" in "core/document.cpp" that can result in Arbitrary file creation on the user workstation. This attack appear to be exploitable via he victim must open a specially crafted Okular archive. This issue appears to have been corrected in version 18.08.1