Use After Free Affecting php5 package, versions <5.6.23+dfsg-0+deb8u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
15.48% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-PHP5-394609
  • published7 Aug 2016
  • disclosed7 Aug 2016

Introduced: 7 Aug 2016

CVE-2016-5771  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Debian:8 php5 to version 5.6.23+dfsg-0+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php5 package and not the php5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

spl_array.c in the SPL extension in PHP before 5.5.37 and 5.6.x before 5.6.23 improperly interacts with the unserialize implementation and garbage collection, which allows remote attackers to execute arbitrary code or cause a denial of service (use-after-free and application crash) via crafted serialized data.

CVSS Base Scores

version 3.1