Improper Input Validation Affecting php5 package, versions <5.2.4-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
7.92% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-PHP5-395112
  • published16 Jul 2007
  • disclosed16 Jul 2007

Introduced: 16 Jul 2007

CVE-2007-3799  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 php5 to version 5.2.4-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php5 package and not the php5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The session_start function in ext/session in PHP 4.x up to 4.4.7 and 5.x up to 5.2.3 allows remote attackers to insert arbitrary attributes into the session cookie via special characters in a cookie that is obtained from (1) PATH_INFO, (2) the session_id function, and (3) the session_start function, which are not encoded or filtered when the new session cookie is generated, a related issue to CVE-2006-0207.

References

CVSS Base Scores

version 3.1