Improper Input Validation Affecting php5 package, versions <5.3.6-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
9.52% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-PHP5-395339
  • published20 Mar 2011
  • disclosed20 Mar 2011

Introduced: 20 Mar 2011

CVE-2011-1470  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 php5 to version 5.3.6-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php5 package and not the php5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The Zip extension in PHP before 5.3.6 allows context-dependent attackers to cause a denial of service (application crash) via a ziparchive stream that is not properly handled by the stream_get_contents function.

CVSS Base Scores

version 3.1