Arbitrary Code Injection Affecting php5 package, versions <5.2.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.7% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-PHP5-395401
  • published10 Sept 2007
  • disclosed10 Sept 2007

Introduced: 10 Sep 2007

CVE-2007-4782  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:8 php5 to version 5.2.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php5 package and not the php5 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

PHP before 5.2.3 allows context-dependent attackers to cause a denial of service (application crash) via (1) a long string in the pattern parameter to the glob function; or (2) a long string in the string parameter to the fnmatch function, accompanied by a pattern parameter value with undefined characteristics, as demonstrated by a "*[1]e" value. NOTE: this might not be a vulnerability in most web server environments that support multiple threads, unless these issues can be demonstrated for code execution.

CVSS Base Scores

version 3.1