Arbitrary Code Injection Affecting php-horde-image package, versions <2.1.0-4+deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.39% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-PHPHORDEIMAGE-282465
  • published21 Jun 2017
  • disclosed21 Jun 2017

Introduced: 21 Jun 2017

CVE-2017-9774  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:8 php-horde-image to version 2.1.0-4+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-horde-image package and not the php-horde-image package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Remote Code Execution was found in Horde_Image 2.x before 2.5.0 via a crafted GET request. Exploitation requires authentication.