Access Restriction Bypass Affecting pigz package, versions <2.2.4-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.34% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-PIGZ-285942
  • published27 Apr 2014
  • disclosed27 Apr 2014

Introduced: 27 Apr 2014

CVE-2013-0296  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Debian:8 pigz to version 2.2.4-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pigz package and not the pigz package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Race condition in pigz before 2.2.5 uses permissions derived from the umask when compressing a file before setting that file's permissions to match those of the original file, which might allow local users to bypass intended access permissions while compression is occurring.

CVSS Base Scores

version 3.1