Inadequate Encryption Strength Affecting polarssl package, versions <1.1.2-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.2% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-POLARSSL-344558
  • published27 Jun 2018
  • disclosed6 Dec 2019

Introduced: 27 Jun 2018

CVE-2012-2130  (opens in a new tab)
CWE-326  (opens in a new tab)

How to fix?

Upgrade Debian:8 polarssl to version 1.1.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream polarssl package and not the polarssl package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

A Security Bypass vulnerability exists in PolarSSL 0.99pre4 through 1.1.1 due to a weak encryption error when generating Diffie-Hellman values and RSA keys.

CVSS Base Scores

version 3.1