Improper Input Validation Affecting polarssl package, versions <1.2.8-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.89% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-POLARSSL-344559
  • published30 Sept 2013
  • disclosed30 Sept 2013

Introduced: 30 Sep 2013

CVE-2013-4623  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 polarssl to version 1.2.8-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream polarssl package and not the polarssl package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The x509parse_crt function in x509.h in PolarSSL 1.1.x before 1.1.7 and 1.2.x before 1.2.8 does not properly parse certificate messages during the SSL/TLS handshake, which allows remote attackers to cause a denial of service (infinite loop and CPU consumption) via a certificate message that contains a PEM encoded certificate.

CVSS Base Scores

version 3.1