Cryptographic Issues Affecting polarssl package, versions <0.14.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.29% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-POLARSSL-344567
  • published20 Jun 2012
  • disclosed20 Jun 2012

Introduced: 20 Jun 2012

CVE-2011-1923  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:8 polarssl to version 0.14.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream polarssl package and not the polarssl package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The Diffie-Hellman key-exchange implementation in dhm.c in PolarSSL before 0.14.2 does not properly validate a public parameter, which makes it easier for man-in-the-middle attackers to obtain the shared secret key by modifying network traffic, a related issue to CVE-2011-5095.

CVSS Base Scores

version 3.1