Cryptographic Issues Affecting polarssl package, versions <1.3.1-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.14% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-POLARSSL-344572
  • published4 Oct 2013
  • disclosed4 Oct 2013

Introduced: 4 Oct 2013

CVE-2013-5915  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:8 polarssl to version 1.3.1-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream polarssl package and not the polarssl package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The RSA-CRT implementation in PolarSSL before 1.2.9 does not properly perform Montgomery multiplication, which might allow remote attackers to conduct a timing side-channel attack and retrieve RSA private keys.

CVSS Base Scores

version 3.1