Cryptographic Issues Affecting polarssl package, versions <1.3.7-2.1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.43% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-POLARSSL-344577
  • published22 Jul 2014
  • disclosed22 Jul 2014

Introduced: 22 Jul 2014

CVE-2014-4911  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:8 polarssl to version 1.3.7-2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream polarssl package and not the polarssl package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The ssl_decrypt_buf function in library/ssl_tls.c in PolarSSL before 1.2.11 and 1.3.x before 1.3.8 allows remote attackers to cause a denial of service (crash) via vectors related to the GCM ciphersuites, as demonstrated using the Codenomicon Defensics toolkit.

CVSS Base Scores

version 3.1