Improper Input Validation Affecting polarssl package, versions <1.1.4-2


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.07% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-POLARSSL-344583
  • published8 Feb 2013
  • disclosed8 Feb 2013

Introduced: 8 Feb 2013

CVE-2013-1621  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 polarssl to version 1.1.4-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream polarssl package and not the polarssl package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Array index error in the SSL module in PolarSSL before 1.2.5 might allow remote attackers to cause a denial of service via vectors involving a crafted padding-length value during validation of CBC padding in a TLS session, a different vulnerability than CVE-2013-0169.

CVSS Base Scores

version 3.1