Arbitrary Code Injection Affecting postgresql-9.1 package, versions <9.1.9-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
54.31% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-POSTGRESQL91-315543
  • published4 Apr 2013
  • disclosed4 Apr 2013

Introduced: 4 Apr 2013

CVE-2013-1899  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Debian:8 postgresql-9.1 to version 9.1.9-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql-9.1 package and not the postgresql-9.1 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Argument injection vulnerability in PostgreSQL 9.2.x before 9.2.4, 9.1.x before 9.1.9, and 9.0.x before 9.0.13 allows remote attackers to cause a denial of service (file corruption), and allows remote authenticated users to modify configuration settings and execute arbitrary code, via a connection request using a database name that begins with a "-" (hyphen).

CVSS Base Scores

version 3.1