Access Restriction Bypass Affecting postgresql-9.4 package, versions <9.4.6-0+deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.11% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-POSTGRESQL94-384909
  • published17 Feb 2016
  • disclosed17 Feb 2016

Introduced: 17 Feb 2016

CVE-2016-0766  (opens in a new tab)
CWE-264  (opens in a new tab)

How to fix?

Upgrade Debian:8 postgresql-9.4 to version 9.4.6-0+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream postgresql-9.4 package and not the postgresql-9.4 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

PostgreSQL before 9.1.20, 9.2.x before 9.2.15, 9.3.x before 9.3.11, 9.4.x before 9.4.6, and 9.5.x before 9.5.1 does not properly restrict access to unspecified custom configuration settings (GUCS) for PL/Java, which allows attackers to gain privileges via unspecified vectors.

CVSS Base Scores

version 3.1