Out-of-Bounds Affecting python-crypto package, versions <2.6.1-5+deb8u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
9.58% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-PYTHONCRYPTO-343454
  • published15 Feb 2017
  • disclosed15 Feb 2017

Introduced: 15 Feb 2017

CVE-2013-7459  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 python-crypto to version 2.6.1-5+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-crypto package and not the python-crypto package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Heap-based buffer overflow in the ALGnew function in block_templace.c in Python Cryptography Toolkit (aka pycrypto) allows remote attackers to execute arbitrary code as demonstrated by a crafted iv parameter to cryptmsg.py.