Out-of-Bounds Affecting python-crypto package, versions <2.0.1+dfsg1-3


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
11.52% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-PYTHONCRYPTO-343477
  • published12 Feb 2009
  • disclosed12 Feb 2009

Introduced: 12 Feb 2009

CVE-2009-0544  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 python-crypto to version 2.0.1+dfsg1-3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-crypto package and not the python-crypto package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Buffer overflow in the PyCrypto ARC2 module 2.0.1 allows remote attackers to cause a denial of service and possibly execute arbitrary code via a large ARC2 key length.

CVSS Base Scores

version 3.1