OS Command Injection Affecting rake package, versions <10.3.2-2+deb8u1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.36% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-RAKE-557083
  • published26 Feb 2020
  • disclosed24 Feb 2020

Introduced: 24 Feb 2020

CVE-2020-8130  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Debian:8 rake to version 10.3.2-2+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rake package and not the rake package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character |.

CVSS Base Scores

version 3.1