Use of Externally-Controlled Format String Affecting rssh package, versions <2.2.2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.7% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-RSSH-345595
  • published23 Oct 2004
  • disclosed23 Oct 2004

Introduced: 23 Oct 2004

CVE-2004-1628  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Debian:8 rssh to version 2.2.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rssh package and not the rssh package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Format string vulnerability in log.c in rssh before 2.2.2 allows remote authenticated users to execute arbitrary code.

CVSS Base Scores

version 3.1