Improper Input Validation Affecting rssh package, versions <2.3.3-6


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.34% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-RSSH-345599
  • published11 Jan 2013
  • disclosed11 Jan 2013

Introduced: 11 Jan 2013

CVE-2012-2251  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 rssh to version 2.3.3-6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rssh package and not the rssh package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

rssh 2.3.2, as used by Debian, Fedora, and others, when the rsync protocol is enabled, allows local users to bypass intended restricted shell access via a (1) "-e" or (2) "--" command line option.

CVSS Base Scores

version 3.1