Out-of-Bounds Affecting sam2p package, versions <0.49.2-3+deb8u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.69% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-SAM2P-273806
  • published22 Sept 2017
  • disclosed22 Sept 2017

Introduced: 22 Sep 2017

CVE-2017-14637  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 sam2p to version 0.49.2-3+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sam2p package and not the sam2p package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

In sam2p 0.49.3, there is an invalid read of size 2 in the parse_rgb function in in_xpm.cpp. However, this can also cause a write to an illegal address.