Out-of-Bounds Affecting sam2p package, versions <0.49.2-3+deb8u2


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.18% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-SAM2P-273815
  • published28 Feb 2018
  • disclosed28 Feb 2018

Introduced: 28 Feb 2018

CVE-2018-7552  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 sam2p to version 0.49.2-3+deb8u2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sam2p package and not the sam2p package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

There is an invalid free in Mapping::DoubleHash::clear in mapping.cpp that leads to a Segmentation fault in sam2p 0.49.4. A crafted input will lead to a denial of service or possibly unspecified other impact.