Cross-site Scripting (XSS) Affecting simplesamlphp package, versions <1.8.2-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.25% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-SIMPLESAMLPHP-306133
  • published24 Jan 2012
  • disclosed24 Jan 2012

Introduced: 24 Jan 2012

CVE-2012-0908  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Debian:8 simplesamlphp to version 1.8.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Cross-site scripting (XSS) vulnerability in logout.php in SimpleSAMLphp 1.8.1 and possibly other versions before 1.8.2 allows remote attackers to inject arbitrary web script or HTML via the link_href parameter.

CVSS Base Scores

version 3.1