Improper Input Validation Affecting simplesamlphp package, versions <1.13.1-2+deb8u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.27% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-SIMPLESAMLPHP-306145
  • published1 Sept 2017
  • disclosed1 Sept 2017

Introduced: 1 Sep 2017

CVE-2017-12874  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 simplesamlphp to version 1.13.1-2+deb8u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream simplesamlphp package and not the simplesamlphp package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The InfoCard module 1.0 for SimpleSAMLphp allows attackers to spoof XML messages by leveraging an incorrect check of return values in signature validation utilities.