CVE-2010-3380 Affecting slurm-llnl package, versions <2.1.15-2


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.3% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-SLURMLLNL-299774
  • published29 Sept 2010
  • disclosed29 Sept 2010

Introduced: 29 Sep 2010

CVE-2010-3380  (opens in a new tab)

How to fix?

Upgrade Debian:8 slurm-llnl to version 2.1.15-2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The (1) init.d/slurm and (2) init.d/slurmdbd scripts in SLURM before 2.1.14 place the . (dot) directory in the LD_LIBRARY_PATH, which allows local users to gain privileges via a Trojan horse shared library in the current working directory.

CVSS Base Scores

version 3.1