Credentials Management Affecting slurm-llnl package, versions <1.3.15-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-SLURMLLNL-299801
  • published16 Jun 2009
  • disclosed16 Jun 2009

Introduced: 16 Jun 2009

CVE-2009-2084  (opens in a new tab)
CWE-255  (opens in a new tab)

How to fix?

Upgrade Debian:8 slurm-llnl to version 1.3.15-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Simple Linux Utility for Resource Management (SLURM) 1.2 and 1.3 before 1.3.14 does not properly set supplementary groups before invoking (1) sbcast from the slurmd daemon or (2) strigger from the slurmctld daemon, which might allow local SLURM users to modify files and gain privileges.

CVSS Base Scores

version 3.1