Out-of-Bounds Affecting udisks package, versions <1.0.5-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.43% (35th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-UDISKS-354145
  • published11 Mar 2014
  • disclosed11 Mar 2014

Introduced: 11 Mar 2014

CVE-2014-0004  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 udisks to version 1.0.5-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream udisks package and not the udisks package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

Stack-based buffer overflow in udisks before 1.0.5 and 2.x before 2.1.3 allows local users to cause a denial of service (crash) and possibly execute arbitrary code via a long mount point.

CVSS Base Scores

version 3.1