Out-of-Bounds Affecting vala-0.26 package, versions <0.26.1-1.1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.8% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-VALA026-262216
  • published27 Jan 2015
  • disclosed27 Jan 2015

Introduced: 27 Jan 2015

CVE-2014-8154  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:8 vala-0.26 to version 0.26.1-1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vala-0.26 package and not the vala-0.26 package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The Gst.MapInfo function in Vala 0.26.0 and 0.26.1 uses an incorrect buffer length declaration for the Gstreamer bindings, which allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via unspecified vectors, which trigger a heap-based buffer overflow.

CVSS Base Scores

version 3.1