Improper Input Validation Affecting weechat package, versions <0.3.9.2-1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.44% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN8-WEECHAT-314647
  • published3 Dec 2012
  • disclosed3 Dec 2012

Introduced: 3 Dec 2012

CVE-2012-5534  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:8 weechat to version 0.3.9.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream weechat package and not the weechat package as distributed by Debian. See How to fix? for Debian:8 relevant fixed versions and status.

The hook_process function in the plugin API for WeeChat 0.3.0 through 0.3.9.1 allows remote attackers to execute arbitrary commands via shell metacharacters in a command from a plugin, related to "shell expansion."

CVSS Base Scores

version 3.1