Cryptographic Issues Affecting at-spi2-atk package, versions <2.5.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-ATSPI2ATK-271101
  • published31 Aug 2012
  • disclosed31 Aug 2012

Introduced: 31 Aug 2012

CVE-2012-3378  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:9 at-spi2-atk to version 2.5.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream at-spi2-atk package and not the at-spi2-atk package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

The register_application function in atk-adaptor/bridge.c in GNOME at-spi2-atk 2.5.2 does not seed the random number generator and generates predictable temporary file names, which makes it easier for local users to create or truncate files via a symlink attack on a temporary socket file in /tmp/at-spi2.

CVSS Base Scores

version 3.1