Out-of-bounds Write Affecting bwa package, versions <0.7.15-2+deb9u1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.91% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-BWA-341898
  • published29 Mar 2019
  • disclosed29 Mar 2019

Introduced: 29 Mar 2019

CVE-2019-10269  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Debian:9 bwa to version 0.7.15-2+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bwa package and not the bwa package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

BWA (aka Burrow-Wheeler Aligner) before 2019-01-23 has a stack-based buffer overflow in the bns_restore function in bntseq.c via a long sequence name in a .alt file.

CVSS Base Scores

version 3.1