Out-of-Bounds Affecting cgminer package, versions <4.4.2-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
2.91% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-CGMINER-338473
  • published23 Jul 2014
  • disclosed23 Jul 2014

Introduced: 23 Jul 2014

CVE-2014-4501  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:9 cgminer to version 4.4.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cgminer package and not the cgminer package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Multiple stack-based buffer overflows in sgminer before 4.2.2, cgminer before 4.3.5, and BFGMiner before 3.3.0 allow remote pool servers to have unspecified impact via a long URL in a client.reconnect stratum message to the (1) extract_sockaddr or (2) parse_reconnect functions in util.c.

CVSS Base Scores

version 3.1