Out-of-Bounds Affecting cgminer package, versions <4.4.2-1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
3.3% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-CGMINER-338480
  • published23 Jul 2014
  • disclosed23 Jul 2014

Introduced: 23 Jul 2014

CVE-2014-4502  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Debian:9 cgminer to version 4.4.2-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cgminer package and not the cgminer package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Multiple heap-based buffer overflows in the parse_notify function in sgminer before 4.2.2, cgminer before 4.3.5, and BFGMiner before 4.1.0 allow remote pool servers to have unspecified impact via a (1) large or (2) negative value in the Extranonc2_size parameter in a mining.subscribe response and a crafted mining.notify request.

CVSS Base Scores

version 3.1