Improper Input Validation Affecting devscripts package, versions <2.11.4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
5.75% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-DEVSCRIPTS-293311
  • published16 Jun 2012
  • disclosed16 Jun 2012

Introduced: 16 Jun 2012

CVE-2012-0211  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 devscripts to version 2.11.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream devscripts package and not the devscripts package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

debdiff.pl in devscripts 2.10.x before 2.10.69 and 2.11.x before 2.11.4 allows remote attackers to execute arbitrary code via a crafted tarball file name in the top-level directory of an original (.orig) source tarball of a source package.

CVSS Base Scores

version 3.1