Improper Input Validation Affecting dnsdist package, versions <1.1.0-2+deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.58% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-DNSDIST-315246
  • published27 Jun 2018
  • disclosed11 Sept 2018

Introduced: 27 Jun 2018

CVE-2016-7069  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Debian:9 dnsdist to version 1.1.0-2+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream dnsdist package and not the dnsdist package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

An issue has been found in dnsdist before 1.2.0 in the way EDNS0 OPT records are handled when parsing responses from a backend. When dnsdist is configured to add EDNS Client Subnet to a query, the response may contain an EDNS0 OPT record that has to be removed before forwarding the response to the initial client. On a 32-bit system, the pointer arithmetic used when parsing the received response to remove that record might trigger an undefined behavior leading to a crash.