Inadequate Encryption Strength Affecting erlang package, versions <1:19.2.1+dfsg-2+deb9u3


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.39% (31st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-ERLANG-571021
  • published18 May 2020
  • disclosed15 May 2020

Introduced: 15 May 2020

CVE-2020-12872  (opens in a new tab)
CWE-326  (opens in a new tab)

How to fix?

Upgrade Debian:9 erlang to version 1:19.2.1+dfsg-2+deb9u3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream erlang package and not the erlang package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

yaws_config.erl in Yaws through 2.0.2 and/or 2.0.7 loads obsolete TLS ciphers, as demonstrated by ones that allow Sweet32 attacks, if running on an Erlang/OTP virtual machine with a version less than 21.0.

CVSS Base Scores

version 3.1