Improper Handling of Exceptional Conditions Affecting eterm package, versions <0.9.6-5+deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
4.09% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-ETERM-1296084
  • published21 May 2021
  • disclosed20 May 2021

Introduced: 20 May 2021

CVE-2021-33477  (opens in a new tab)
CWE-755  (opens in a new tab)

How to fix?

Upgrade Debian:9 eterm to version 0.9.6-5+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream eterm package and not the eterm package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

rxvt-unicode 9.22, rxvt 2.7.10, mrxvt 0.5.4, and Eterm 0.9.7 allow (potentially remote) code execution because of improper handling of certain escape sequences (ESC G Q). A response is terminated by a newline.

References

CVSS Base Scores

version 3.1