SQL Injection Affecting firebird3.0 package, versions <3.0.1.32609.ds4-14+deb9u1


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
6.15% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-FIREBIRD30-277248
  • published28 Mar 2018
  • disclosed28 Mar 2018

Introduced: 28 Mar 2018

CVE-2017-11509  (opens in a new tab)
CWE-89  (opens in a new tab)

How to fix?

Upgrade Debian:9 firebird3.0 to version 3.0.1.32609.ds4-14+deb9u1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream firebird3.0 package and not the firebird3.0 package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

An authenticated remote attacker can execute arbitrary code in Firebird SQL Server versions 2.5.7 and 3.0.2 by executing a malformed SQL statement.

CVSS Base Scores

version 3.1