Cryptographic Issues Affecting geary package, versions <0.6.3-1


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.09% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-DEBIAN9-GEARY-338550
  • published30 Sept 2014
  • disclosed30 Sept 2014

Introduced: 30 Sep 2014

CVE-2014-5444  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Debian:9 geary to version 0.6.3-1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream geary package and not the geary package as distributed by Debian. See How to fix? for Debian:9 relevant fixed versions and status.

Geary before 0.6.3 does not present the user with a warning when a TLS certificate error is detected, which makes it easier for remote attackers to conduct man-in-the-middle attacks via a crafted certificate.

CVSS Base Scores

version 3.1