Improper Input Validation Affecting git package, versions <1:2.11.0-3+deb9u5


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high
Expand this section
SUSE
8.8 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-GIT-537126
  • published 10 Dec 2019
  • disclosed 24 Jan 2020

How to fix?

Upgrade Debian:9 git to version 1:2.11.0-3+deb9u5 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See How to fix? for Debian:9 relevant versions.

A remote code execution vulnerability exists when Git for Visual Studio improperly sanitizes input, aka 'Git for Visual Studio Remote Code Execution Vulnerability'. This CVE ID is unique from CVE-2019-1349, CVE-2019-1350, CVE-2019-1354, CVE-2019-1387.