CVE-2019-1348 Affecting git package, versions <1:2.11.0-3+deb9u5


0.0
low

Snyk CVSS

    Attack Complexity Low
Expand this section
NVD
3.3 low
Expand this section
SUSE
3.3 low
Expand this section
Red Hat
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-DEBIAN9-GIT-537164
  • published 10 Dec 2019
  • disclosed 24 Jan 2020

How to fix?

Upgrade Debian:9 git to version 1:2.11.0-3+deb9u5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream git package and not the git package as distributed by Debian:9. See How to fix? for Debian:9 relevant fixed versions and status.

An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. The --export-marks option of git fast-import is exposed also via the in-stream command feature export-marks=... and it allows overwriting arbitrary paths.